
Upgrading GigaStor to version 13

This is intended to assist current GigaStor users with their disk drive 
conversions to version 13. Prior to version 13, data was stored on the 
RAID array hard drives on a first-come first-served basis. This allowed 
monitoring instances that received large amounts of traffic to use 
more hard drive space than monitoring instances that received less 
traffic. Over time this lead to less and less disk space available for the 
lower traffic monitoring instances, and could eventually lead to no 
available disk space for these monitoring instances. 

In version 13, the data is stored in a different format allowing you to 
configure the amount of disk space to be used on a per monitoring 
instance basis. This removes the data hogging issue and allows more 
flexibility for data storage. However, all data prior to version 13 is 
deleted. 

Installation requirements

1 Back up any GigaStor data you want to keep.

2 Have the following available:

License numbers for version 13

Observer 13 setup application. The latest version can be 
downloaded from the following FTP site: ftp://
ftp.networkinstruments.com/pub/demos/observersetup.exe
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3 As part of the GigaStor upgrade process, the GigaStor deletes the 
version 12 data. This process can take a significant amount of time 
(up to several hours). We suggest that you format your data drive 
(typically D:) before continuing with step 4. By formatting the 
drive, you will lose all data. You should back up any user-saved 
files you wish to keep.

4 Complete one of the following based on how you are currently 
using Observer and the GigaStor. For ease of installation, we do 
not recommend that you do a manual installation if your GigaStor 
software is currently running as a Windows service. If your 
GigaStor is running as a Windows service, recommend you use 
the auto-upgrade feature. 

“Upgrading using Auto-Upgrade” on page 3. 

“Upgrading using manual installation — Probe running as a 
Windows service” on page 5.

“Upgrading using manual installation — Probe running in 
Console View” on page 6.

5 Configure the GigaStor disk array. See “Configuring the GigaStor 
disk array” on page 8.

CAUTION ABOUT
ERASING DATA

Configuring the disk array erases any existing data. Data from
version 11 or 12 cannot be loaded into the version 13
GigaStor control panel. Your existing data, however, can be
saved to a remote data storage device and the .BFR files can
be loaded into Observer to be viewed within the standard
decode screen.

NOTE: FIRMWARE
UPGRADE

Gen2 and Gen2a (Gigabit Capture Adapter): Version 13
contains a new firmware for any Gen2 or Gen2a. Your
GigaStor will power off if its firmware was updated on a
Gen2 or Gen2a capture adapter during the installation
process. It must be manually restarted. 

10Gb Capture Adapter: Version 13 may contain a firmware
upgrade for your 10Gig capture adapters. 10Gig systems will
not power off even if the firmware is upgraded. This is due to
the difference between PCI-E and PCI-X. PCI-X requires a
loss of power to reset the PCI-X bus, whereas PCI-E only
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requires a restart to reset the bus. For the firmware change to
take affect, the bus must reset.

Upgrading using Auto-Upgrade

These steps assume you have not upgraded any of your consoles or 
GigaStor systems to version 13. First upgrade your local console, then 
upgrade your GigaStor. If you have already installed version 13 on 
your console, you may jump to step 11.

1 Close Observer on your local system by clicking File → Exit.

2 Launch Windows Task Manager and verify that the following 
processes are not running. You can launch the Task Manager by 
pressing Ctrl+Alt+Del or if using Remote Desktop by right-
clicking the Task Bar and choosing Task Manager.

Observer.exe

NiPagingServer.exe

NiWsd.exe

If any of these processes are running, either wait 60 seconds for 
them to close automatically, or end the task by clicking the 
process and choosing End Task.

3 Launch the ObserverSetup.exe executable. Click Next through 
the screens choosing the options appropriate for you.

4 On the Choose to Install Observer or Probe screen, select 
Observer.

5 Verify the path for the installation is 

64-Bit systems: C:\Program Files (x86)\Observer

32-Bit systems: C:\Program Files\Observer

6 Click Next. The installation takes about a minute. Afterwards, 
restart the system.

7 After the system restarts, click Start → All Programs → Observer 
→ Observer to launch the software.
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8 Select Time Limited Functional Demo from the splash screen.

9 From the main Observer console, click Help → License Observer 
and type your license numbers and click OK.

10 Close Observer and open Observer to launch Observer in a 
licensed mode.

11 After Observer opens you may receive messages stating that 
probes are attempting to connect that are older than the currently 
installed version. Click OK on any of these messages.

12 On the left side of your Observer console, select a monitoring 
instance from your GigaStor and right-click that monitoring 
instance and choose Select Probe or Device Properties.

13 Click OK on the message that states that the probe is currently 
not connected.

14 After the Probe or Device Properties box opens, click the Auto 
upgrade tab.

15 Select Auto upgrade probe for a Major version release.

16 Click the Enter License Information button.

17 Select the Enter Expert Probe or redirected Observer monitoring 
instance licensing information and type the licensing information 
for your GigaStor and click OK. 

18 Click OK to exit the Probe or Device Properties screen.

19 The next time the probe attempts to connect, Observer passes the 
upgrade files. The remote probe will disconnect, install its 
software and restart. See “Firmware upgrade” on page 2 for more 
details. After the restart has completed, the probe connects to 
your system.

You have successfully upgraded your local Observer Console and 
GigaStor device to version 13. To complete the configuration, see 
“Configuring the GigaStor disk array” on page 8.

NOTE:
Your GigaStor software must be setup to run as a Windows
service and set to restart after an upgrade for step 19 to work
properly. If it is not setup to run as a Windows service or not
Upgrading using Auto-Upgrade
 Upgrading GigaStor to version 13

4
rev. 2



setup to restart, you must manually restart the system to
complete the upgrade.

Upgrading using manual installation — Probe running as 
a Windows service

1 Stop the GigaStor software. Click Start → Control Panel → 
Administrative Tools → Services. 

2 Select the Network Instruments Expert Probe Service. Click 
Action (Menu) → Stop. This stops the Network Instruments 
Expert Probe (GigaStor).

3 Close the Network Instruments Probe Service Configuration 
Applet. Right-click the Network Instruments Service 
Configuration Applet and select Close Probe Service 
Configuration Applet.

This icon is located in the bottom right corner of the screen in the 
Windows system tray. There is a blue icon called the Network 
Instruments Probe Service Configuration Applet. 

Figure 1  Probe Service Configuration Applet

4 Launch Windows Task Manager and verify that the following 
processes are not running. You can launch the Task Manager by 
pressing Ctrl+Alt+Del or if using Remote Desktop by right-
clicking the Task Bar and choosing Task Manager.

Observer.exe

NiSrvConfig.exe

NiPagingServer.exe

NiWsd.exe (If GigaStor Suite only)

NiExpertProbeSrv.srv
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If any of these processes are running, either wait 60 seconds for 
them to close automatically, or end the task by clicking the 
process and choosing End Task.

5 Launch the ObserverSetup.exe executable. Click Next through 
the screens choosing the options appropriate for you.

6 On the Choose to Install Observer or Probe screen, select Expert 
Probe.

7 Verify the path for the installation is 

64-Bit systems: C:\Program Files (x86)\Observer

32-Bit systems: C:\Program Files\Observer

8 Click Next. The installation takes several minutes due to a 
firmware update. Afterwards, restart the system.

After the system restarts, your GigaStor software attempts to run 
as a Windows service, but due to its license number not being 
updated it will not launch properly. The probe service must be 
stopped to continue. Follow step 1 to stop the probe service then 
continue with step 9.

9 Click Start → Programs → Expert Probe → Expert Probe to 
launch the software.

10 When the application launches it prompts you to type your 
licensing information. Type your version 13 license number and 
click OK.

You have now successfully updated the software. To complete the 
configuration, see “Configuring the GigaStor disk array” on page 8.

Upgrading using manual installation — Probe running in 
Console View

1 Close the Observer console software by clicking File → Exit.

2 Launch Windows Task Manager and verify that the following 
processes are not running. You can launch the Task Manager by 
pressing Ctrl+Alt+Del or if using Remote Desktop by right-
clicking the Task Bar and choosing Task Manager.
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Observer.exe

NiPagingServer.exe

NiWsd.exe 

If any of these processes are running, either wait 60 seconds for 
them to close automatically, or end the task by simply clicking the 
process and choosing End Task.

3 Launch the ObserverSetup.exe executable. Click Next through 
the screens choosing the options appropriate for you.

4 On the Choose to Install Observer or Probe screen, select 
Observer.

5 Verify the path for the installation is 

64-Bit systems: C:\Program Files (x86)\Observer

32-Bit systems: C:\Program Files\Observer

Then click Next.

6 The installation of the new software takes approximately 10 
minutes due to the firmware update. Afterwards when prompted 
to shutdown (gen2) or restart (10Gig), select the shutdown or 
restart option. 

7 Click Start → Programs → Observer → Observer to launch the 
software.

8 Select Time Limited Functional from the splash screen.

9 From the main Observer console, click Help → License Observer 
and type your license numbers. 

10 Click OK to license.

11 Close and reopen Observer to open Observer in licensed mode.

You have now successfully updated the software. To complete the 
configuration, see “Configuring the GigaStor disk array” on page 8.
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Configuring the GigaStor disk array

CAUTION ABOUT
ERASING DATA

This process erases any existing data. Data from version 11 or
12 data cannot be loaded into the version 13 GigaStor control
panel. Your existing data, however, can be saved to a remote
data storage device and the .BFR files can be loaded into the
application to be viewed within the standard decode screen.

1 Use Windows Remote Desktop to connect to the GigaStor unit.

2 Choose the option below depending on whether you are running 
as a probe or as a console.

Console: Click Options → Selected Probe or Local Observer 
monitoring instance Memory and Security Administration.

Probe running as a Windows Service: Stop the probe service 
through Windows Control Panel. Then launch the probe from 
the Start→Programs menu.

3 Click the GigaStor Instances tab.

4 Click one of your active monitoring instances. 

5 Click the Configure Disk Space Reserved for Selected monitoring 
instance.

6 If you did not complete step 3 on page 2 a message appears 
stating that by continuing your version 12 data will be deleted. If 
you are ready to proceed, click Delete.

7 A screen appears that shows you the amount of hard drive space 
available to allocate for the selected monitoring instance. Any 
hard drive space you allocate for this monitoring instance is not be 
available for any other active monitoring instance. 

Passive monitoring instances will not use this space. Therefore, 
there is no need to worry about allocating hard drive space for 
passive monitoring instances. We recommend you have only one 
active monitoring instance and allocate all available hard drive 
space to it. You may choose to have multiple active monitoring 
instances, but then you must allocate some space to it and save 
some space for the other active monitoring instances.
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Figure 2  Disk Space Reserved for Selected Instance

8 Click OK to exit this screen.

9 You have now allocated hard drive space for the first active 
monitoring instance. If you have other active monitoring instances 
you can allocate hard drive space for them, by clicking another 
active monitoring instance, then clicking the Configure Disk 
Space Reserved for Selected monitoring instance then following 
the step 7 and step 8.

Figure 3  GigaStor Instances tab

10 After you have allocated all the disk space for each active 
monitoring instance, click OK. 
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11 After you start running the GigaStor Control Panel, data is 
written to the new hard drive space. You must open the GigaStor 
Control Panel screen for this to take place even if you have 
scheduling configured. The disk space will not actually be 
allocated until the GigaStor Control Panel is opened for each 
active monitoring instance.

You have now completed the steps allocate hard drive space on your 
GigaStor unit.
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